StayNTouch Cloud PMS Outage
Incident Report for Stayntouch
Resolved
This incident has been resolved.
Posted Aug 12, 2021 - 12:51 EDT
Investigating
StayNTouch Cloud PMS is currently down; however, our team is actively working on resolving this outage as soon as possible. We will post an announcement when this is resolved. We apologize for the inconvenience.
Posted Aug 12, 2021 - 12:28 EDT
This incident affected: Stayntouch PMS, Stayntouch Guest Mobility, Stayntouch Guest Kiosk, Imports, Reports, Connect APIs, Interfaces, and Guest Email Notifications.